Limit SAML support to Python <= 3.10

Review Request #12592 — Created Sept. 12, 2022 and submitted

Information

Review Board
release-5.0.x

Reviewers

The python3-saml in our SAML dependencies requires lxml < 4.7.1, however this
fails to compile on Python 3.11. This change skips the SAML dependencies when
setting up for Python 3.11.

Ran python3.11 ./setup.py develop successfully.

Summary ID
Limit SAML support to Python <=3.10
cdbf26d1657c855648ccce7dfb43fcac84b3c825
mend
d00d54047d9fc5abaef5c5cc28eec97ffd4bf4af
Description From Last Updated

There's a trailing space and a missing period. Can you add a space around the </<= operators throughout the comment?

chipx86chipx86
chipx86
  1. 
      
  2. dev-requirements.txt (Diff revision 1)
     
     

    There's a trailing space and a missing period.

    Can you add a space around the </<= operators throughout the comment?

  3. 
      
maubin
chipx86
  1. Ship It!
  2. 
      
maubin
Review request changed

Status: Closed (submitted)

Change Summary:

Pushed to release-5.0.x (3ed43a6)
Loading...