flake8
-
reviewboard/datagrids/builtin_items.py (Diff revision 1) Show all issues -
-
-
-
reviewboard/reviews/models/review_request_draft.py (Diff revision 1) E124 closing bracket does not match visual indentation
Review Request #9246 — Created Oct. 9, 2017 and discarded
Information | |
---|---|
mukhtar | |
Review Board | |
master | |
Reviewers | |
reviewboard, students | |
When user login to Review Board dashboard, they would like
to see all their open requests from incoming and outgoing.
Therefore, adding a new section that is called 'My Reviews'
will allow users to see all their open requests.
Added a unit test, which passes (along with all other tests).
Description | From | Last Updated |
---|---|---|
E501 line too long (118 > 79 characters) |
![]() |
|
E302 expected 2 blank lines, found 0 |
![]() |
|
E501 line too long (118 > 79 characters) |
![]() |
|
W291 trailing whitespace |
![]() |
|
It looks like your project code and your bug fix code got combined together. This shouldn't be part of this … |
|
|
E124 closing bracket does not match visual indentation |
![]() |
|
E501 line too long (118 > 79 characters) |
![]() |
|
E302 expected 2 blank lines, found 0 |
![]() |
|
E501 line too long (118 > 79 characters) |
![]() |
|
E501 line too long (122 > 79 characters) |
![]() |
|
E501 line too long (118 > 79 characters) |
![]() |
|
E302 expected 2 blank lines, found 0 |
![]() |
|
E501 line too long (118 > 79 characters) |
![]() |
|
E501 line too long (122 > 79 characters) |
![]() |
|
E501 line too long (125 > 79 characters) |
![]() |
|
E999 IndentationError: unindent does not match any outer indentation level |
![]() |
|
This isn't correct (copy/paste-o?) |
|
|
This should have a "Yields:" section. See https://www.notion.so/reviewboard/Writing-Codebase-Documentation-e16312b5f061437cb73cbfa369ac3cb5 |
|
|
The view ID should use a hyphen rather than an underscore. |
|
|
I suspect we want this to be the first item in the sidebar. |
|
|
This should probably be changed to "My open outgoing review requests" |
|
|
This should probably be changed to "All my open outgoing review requests" |
|
|
We should change this to use sentence casing rather than title casing. |
|
|
Can we put this as the first thing checked? The view string should also have a hyphen instead of an … |
|
|
This should probably be "My open incoming and outgoin review requests" |
|
|
Should change this to be sentence casing. |
|
|
Should change this to be sentence casing. |
|
|
Should change this to be sentence casing. |
|
|
Should change this to be sentence casing. |
|
|
This should probably be named get_my_reviews_query to match other, similar method names. |
|
|
The docstring here needs "Args:" and "Returns:" sections. See https://www.notion.so/reviewboard/Writing-Codebase-Documentation-e16312b5f061437cb73cbfa369ac3cb5 for some info on these. |
|
|
E128 continuation line under-indented for visual indent |
![]() |
|
W503 line break before binary operator |
![]() |
|
E128 continuation line under-indented for visual indent |
![]() |
|
W503 line break before binary operator |
![]() |
|
This needs a docstring (I know others don't have them but they're old code). |
|
|
Can we call the column "my_reviews_count" to match the name used elsewhere? "my review request count" sounds almost like it's … |
|
|
W292 no newline at end of file |
![]() |
|
This needs a "Yields" section. |
|
|
typo: outgoin |
|
|
This shouldn't include the word "open", since it's all including both open and closed. |
|
|
This should be in the imperative mood ("Return" instead of "Returns"). This docstring also needs Args/Returns sections. |
|
|
This needs a docstring. |
|
|
New file should include module docstring. |
|
|
Maybe add a description of what get_my_reviews_query does, and add as an additional note that it's meant to be passed … |
|
reviewboard/datagrids/builtin_items.py (Diff revision 1) |
---|
reviewboard/reviews/models/review_request_draft.py (Diff revision 1) |
---|
E124 closing bracket does not match visual indentation
reviewboard/reviews/models/review_request_draft.py (Diff revision 1) |
---|
It looks like your project code and your bug fix code got combined together. This shouldn't be part of this change. If you need help untangling this, please ping @mentors in slack.
Description: |
|
|||||||||
---|---|---|---|---|---|---|---|---|---|---|
Branch: |
|
|||||||||
Commit: |
|
|||||||||
Diff: |
Revision 2 (+29) |
Commit: |
|
||||
---|---|---|---|---|---|
Diff: |
Revision 3 (+85) |
reviewboard/reviews/managers.py (Diff revision 3) |
---|
E999 IndentationError: unindent does not match any outer indentation level
Commit: |
|
||||
---|---|---|---|---|---|
Diff: |
Revision 4 (+59) |
reviewboard/reviews/managers.py (Diff revision 4) |
---|
E128 continuation line under-indented for visual indent
reviewboard/reviews/managers.py (Diff revision 4) |
---|
E128 continuation line under-indented for visual indent
reviewboard/datagrids/builtin_items.py (Diff revision 4) |
---|
This should have a "Yields:" section. See https://www.notion.so/reviewboard/Writing-Codebase-Documentation-e16312b5f061437cb73cbfa369ac3cb5
reviewboard/datagrids/builtin_items.py (Diff revision 4) |
---|
The view ID should use a hyphen rather than an underscore.
reviewboard/datagrids/grids.py (Diff revision 4) |
---|
I suspect we want this to be the first item in the sidebar.
reviewboard/datagrids/grids.py (Diff revision 4) |
---|
This should probably be changed to "My open outgoing review requests"
reviewboard/datagrids/grids.py (Diff revision 4) |
---|
This should probably be changed to "All my open outgoing review requests"
reviewboard/datagrids/grids.py (Diff revision 4) |
---|
We should change this to use sentence casing rather than title casing.
reviewboard/datagrids/grids.py (Diff revision 4) |
---|
Can we put this as the first thing checked? The view string should also have a hyphen instead of an underscore.
reviewboard/datagrids/grids.py (Diff revision 4) |
---|
This should probably be "My open incoming and outgoin review requests"
reviewboard/reviews/managers.py (Diff revision 4) |
---|
This should probably be named
get_my_reviews_query
to match other, similar method names.
reviewboard/reviews/managers.py (Diff revision 4) |
---|
The docstring here needs "Args:" and "Returns:" sections. See https://www.notion.so/reviewboard/Writing-Codebase-Documentation-e16312b5f061437cb73cbfa369ac3cb5 for some info on these.
reviewboard/reviews/managers.py (Diff revision 4) |
---|
This needs a docstring (I know others don't have them but they're old code).
Commit: |
|
||||
---|---|---|---|---|---|
Diff: |
Revision 5 (+66 -8) |
Commit: |
|
||||
---|---|---|---|---|---|
Diff: |
Revision 6 (+86 -9) |
reviewboard/accounts/evolutions/total_my_review_request_count.py (Diff revision 6) |
---|
W292 no newline at end of file
reviewboard/accounts/admin.py (Diff revision 6) |
---|
Can we call the column "my_reviews_count" to match the name used elsewhere? "my review request count" sounds almost like it's the outgoing review requests.
reviewboard/datagrids/grids.py (Diff revision 6) |
---|
This shouldn't include the word "open", since it's all including both open and closed.
reviewboard/reviews/managers.py (Diff revision 6) |
---|
This should be in the imperative mood ("Return" instead of "Returns").
This docstring also needs Args/Returns sections.
Summary: |
|
||||||||||||||||||
---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|
Description: |
|
||||||||||||||||||
Testing Done: |
|
||||||||||||||||||
Commit: |
|
||||||||||||||||||
Diff: |
Revision 7 (+129 -10) |
Summary: |
|
||||
---|---|---|---|---|---|
Commit: |
|
||||
Diff: |
Revision 8 (+149 -10) |
Commit: |
|
||||
---|---|---|---|---|---|
Diff: |
Revision 9 (+150 -10) |
reviewboard/accounts/evolutions/total_my_reviews_count.py (Diff revision 9) |
---|
New file should include module docstring.
reviewboard/reviews/managers.py (Diff revision 9) |
---|
Maybe add a description of what get_my_reviews_query does, and add as an additional note that it's meant to be passed to ReviewRequest.objects.public()
Commit: |
|
||||
---|---|---|---|---|---|
Diff: |
Revision 10 (+152 -10) |