Rename pageView to basePageView to get around adblockers
Review Request #9202 — Created Sept. 22, 2017 and submitted
Apparently pageView is a common name for some ad network and ad blockers
will prevent the file from loading from the development server.
Verified that the file is not blocked from loading by my ad blocker.
The class name should be renamed to match. Description could use a little more fleshing out. Testing Done as well ...