Improve naming of entry-related Less variables and move to defs.less.
Review Request #9175 - Created Sept. 6, 2017 and submitted
This moves the entry-related variables out of reviews.less and into
defs.less, renaming them in the process in order to have a more
consistent naming scheme and to make these available to extensions that
may want to reference them. No actual styling has changed.
Tested that the entries still render correctly.