Change "box" terminology to "entry" for the review request page.

Review Request #9110 — Created July 31, 2017 and submitted

Christian Hammond
Review Board

This updates the JavaScript for the review request page to use "entry"
instead of "box" for the terminology, helping to make the code a bit
more readable and clear. It also fixes up some of the event and anchor
handling to be more efficient.

Tested that collapsing/expanding all and individual entries worked.

Tested entry expansion when anchors are referenced.

Unit tests pass.

David Trowbridge
  1. Ship It!
Christian Hammond
Review request changed

Status: Closed (submitted)

Change Summary:

Pushed to release-3.0.x (33127d8)