Reorganize the review request entry-related JavaScript files.

Review Request #9092 - Created July 20, 2017 and submitted

Christian Hammond
Review Board
release-3.0.x
cf1d769...
reviewboard

Recently, the js/reviewRequestPage/ directory was creating to house
the models for backing review request page entries. Each model in here
lived in the RB. namespace, with ReviewRequestPage prefixed to the
model name, making the filenames quite long and setting a bad precedent
for future classes. We also had all the view classes living in a
different location using "box" instead of "entry" in the names.

This change begins some cleanup of these directories, helping with
organizing things before some upcoming work on dynamic reloading. The
model filenames are now simpler, chopping off the reviewRequestPage
prefix, and the models themselves now live in a RB.ReviewRequestPage
namespace.

The box views have been moved into js/reviewRequestPage/views/ and
renamed to use the Entry terminology. The base class,
CollapsableBoxView, has been renamed to EntryView, which will be
more suitable given some of its upcoming responsibilities.

These files have also been moved out of the reviews Pipeline bundle
and into a new review-request-page bundle. This will slim down the
diff viewer and file attachment pages a bit. In time, more files will
move to this bundle.

Unit tests all run.

Tested all the functionality of the various types of entries on the
review request page. This included:

  • Collapsing/expanding boxes (all at once and one-at-a-time)
  • Loading comments.
  • Replying to comments.
  • Viewing status updates.
  • Viewing and working with content on the change entries.
  • 0
  • 0
  • 0
  • 4
  • 4
Description From Last Updated
David Trowbridge
Christian Hammond
Review request changed

Status: Closed (submitted)

Change Summary:

Pushed to release-3.0.x (5d6d0c5)
Loading...