flake8
-
reviewboard/hostingsvcs/github.py (Diff revision 1) Show all issues -
-
Review Request #9028 — Created June 20, 2017 and discarded
Information | |
---|---|
james909fdsa | |
Review Board | |
release-2.5.x | |
Reviewers | |
reviewboard | |
Previously, a user could only configure a repository within the user or an organization. With the addition of this plan, a user will be able to configure another user's repository by entering the user's name and desired repository. The error messages for all plans were also updated by using dictionaries and %s to get the user's name and repo's name, rather than outputting a static string.
Ran unit tests with and without parameters, and had no errors.
Manually tested user:chipx86 and repository name:baseconfigs.git,
and it worked with no errors.When the plan is tested with random inputs for both username and
repo name, we are given the correct error message.
Description | From | Last Updated |
---|---|---|
E501 line too long (84 > 79 characters) |
![]() |
|
E501 line too long (84 > 79 characters) |
![]() |
|
E303 too many blank lines (2) |
![]() |
|
Let's use "Owner's username" |
|
|
"org_name" should be "other_username" |
|
|
Should use "other_username" ("username" is one word). Note that this won't apply to the github_other_user_name variables below, because that's actually … |
|
|
"other_username" |
|
|
"Desired" might be confusing to a lot of users, particularly non-English speakers. "Other User's Repository" would be better. |
|
|
"username" isn't right here. Let's use "owner". |
|
|
These can be combined to one line, I believe. |
|
|
No blank line here. |
|
|
Let's extend this to say: " ... was not found, or is not publicly-accessible." |
|
|
No blank line here. |
|
|
No blank line here. |
|
|
These are only relevant to organizations. You don't want them for this plan. |
|
|
Only one blank line here. |
|
|
Can you put each argument on its own line? |
|
|
Let's swap the order of these, so that it'll match the order in which they're presented in the form. This … |
|
reviewboard/hostingsvcs/github.py (Diff revision 1) |
---|
Testing Done: |
|
|||||||||||||||||||||||||||
---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|
Commit: |
|
|||||||||||||||||||||||||||
Diff: |
Revision 2 (+124 -24) |
reviewboard/hostingsvcs/github.py (Diff revision 2) |
---|
Should use "other_username" ("username" is one word). Note that this won't apply to the
github_other_user_name
variables below, because that's actually built asgithub_<planid>_<fieldname>
.
reviewboard/hostingsvcs/github.py (Diff revision 2) |
---|
"Desired" might be confusing to a lot of users, particularly non-English speakers.
"Other User's Repository" would be better.
reviewboard/hostingsvcs/github.py (Diff revision 2) |
---|
Let's extend this to say:
" ... was not found, or is not publicly-accessible."
reviewboard/hostingsvcs/github.py (Diff revision 2) |
---|
These are only relevant to organizations. You don't want them for this plan.
reviewboard/hostingsvcs/tests/test_github.py (Diff revision 2) |
---|
Can you put each argument on its own line?
reviewboard/hostingsvcs/tests/test_github.py (Diff revision 2) |
---|
Let's swap the order of these, so that it'll match the order in which they're presented in the form. This is just for readability purposes and consistency with the other tests.
Testing Done: |
|
|||||||||||||||||||||||||||
---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|
Commit: |
|
|||||||||||||||||||||||||||
Diff: |
Revision 3 (+119 -24) |