Require a newer version of Pygments for 2.0.x.

Review Request #8805 - Created March 9, 2017 and submitted

Christian Hammond
Review Board
release-2.0.x
4f465cb...
reviewboard
The minimum version of Pygments on 2.0.x was pretty old, and in practice
most people ended up with a newer version installed anyway. Part of the
problem of having an older version is that modern versions generate HTML
slightly differently, and our unit tests weren't updated for the newer
output.

We now require the same version that Review Board 2.5 requires, and
tests have been updated accordingly.

Installed in a new virtualenv. Unit tests pass.

Review Bot
Barret Rennie
Christian Hammond
Review request changed

Status: Closed (submitted)

Change Summary:

Pushed to release-2.0.x (b9a1bed)
Loading...