Fix an issue with dynamic loading of diff fragments

Review Request #677 — Created Dec. 18, 2008 and submitted

russell
Review Board SVN (deprecated)
reviewboard
After installing a new reviewboard instance, I had some trouble with viewing the details of a review request.  The dynamic loading of diff fragments was broken.  "Loading diff fragment..." never went away.  We tracked it down to a missing script.  This patch fixed it for me.
Retrieving diff fragments on this box works now, where it didn't before.
OR
  1. Did this happen from a clean install of both Review Board and Djblets?
    
    I upgraded RB recently, but found that Djblets did not get also upgraded to the latest and so was missing some essential jQuery scripts.
    
    Wiping out Djblets then reinstalling fixed it for me without having to alter RB.
    1. Yeah.  It happened with a clean install from 2008-12-05.  So, I updated both Review Board and Djblets on 2008-12-17 and it was still happening.
      
      It is certainly possible that I broke something that I don't know about.  If this patch isn't correct, then it's no big deal.  I just know that I somehow got my system in a broken state, and that this change fixed it.  :-)
  2. 
      
chipx86
  1. Thanks. Wonder how that broke. Fixed in r1638.
  2. 
      
Loading...