generalize postreview.py

Review Request #3670 — Created Dec. 15, 2012 and discarded

mw_triad
RBTools
master
rbtools
Rename postreview.py to reviewtool.py, and modify it to take additionally an action to perform. Add a stub to implicitly take the new 'post' action. Modify setup.py so that the post-review wrapper will call this stub.
    
This will permit adding other actions which can take advantage of the general functionality in what is now reviewtool.py (e.g. finding the server, logging in) without needing to duplicate this code elsewhere.

(Further rationale: I intend to follow this with an addition to reviewtool.py to add a 'submit' action, which will take a request ID and change its status to 'submitted'.)


MW
MW
SM
  1. Hey Matthew,
    
    There is currently an ongoing effort to shift rbtools to something like this. If you take a look in the api branch of the repo, the 'rb' command is being developed, along with a number of subcommands for carrying out tasks (post, attach, patch, diff, etc.).
    
    There is still work to be done until a release, but we're getting close. Here are some of the relevant review requests:
    http://reviews.reviewboard.org/r/3449/
    http://reviews.reviewboard.org/r/3612/
    http://reviews.reviewboard.org/r/3440/
    http://reviews.reviewboard.org/r/3429/
    http://reviews.reviewboard.org/r/3627/
    http://reviews.reviewboard.org/r/3599/
    http://reviews.reviewboard.org/r/3595/
    
    I encourage any effort towards generalizing post review be made in line with these changes. If you'd like to be involved in this effort, there is plenty to be done, and we could discuss it on the reviewboard-dev mailing list.
  2. 
      
MW
Review request changed

Status: Discarded

Loading...