-
-
-
reviewboard/static/rb/css/action-feed.less (Diff revision 1) These should be witihn the .action_feed or whatever the container is. Otherwise, it's just too generic.
-
-
reviewboard/static/rb/js/action-feed.js (Diff revision 1) The ) shouldn't be on their own lines. Same comments for others in this file.
-
reviewboard/static/rb/js/action-feed.js (Diff revision 1) The variables need to be indented. We call collapse_button.parent() more than once, so let's cache that into a variable first.
-
-
reviewboard/static/rb/js/action-feed.js (Diff revision 1) Can you do one per line? It'll be easier to read.
-
-
-
reviewboard/static/rb/js/action-feed.js (Diff revision 1) I think this would be nicer as: get_reply_text(comment).appendTo( reply_comments.append($('<dt/>') ...) Same comments below.
-
-
-
-
-
-
-
reviewboard/webapi/resources.py (Diff revision 1) Not sure we want to remove this, since it's a core part of the data on the action. Why's it removed?
-
reviewboard/webapi/resources.py (Diff revision 1) What's this being used for? I'd prefer we call this "replied_to". This would require a serialize_replied_to function.
-
reviewboard/webapi/resources.py (Diff revision 1) I'm hesitant to say "comment" here. How about "The review that this is replying to."
[WIP] Expand the action-feed boxes for replies
Review Request #3272 — Created Aug. 11, 2012 and discarded
Information | |
---|---|
bogdana | |
Review Board | |
Reviewers | |
reviewboard | |
The title is self-explanatory, I hope. I'm not particularly happy with the way it looks, so any improvement suggestions will be appreciated. As for the implementation, I added the 'base_reply_to' field to the ReviewReplyResource so I could get the body_top and body_bottom text of the original review. If this is ok, then we could probably drop the get_base_reply_to_field method in the same class. Still TODO: eliminate duplication between the javascript functions for expanding review and reply boxes
Description | From | Last Updated |
---|---|---|
This blank line isn't needed. |
|
|
These should be witihn the .action_feed or whatever the container is. Otherwise, it's just too generic. |
|
|
This can be one return statement. |
|
|
The ) shouldn't be on their own lines. Same comments for others in this file. |
|
|
The variables need to be indented. We call collapse_button.parent() more than once, so let's cache that into a variable first. |
|
|
Can be one statement. |
|
|
Can you do one per line? It'll be easier to read. |
|
|
One per line. |
|
|
Initialize it when defining it. |
|
|
I think this would be nicer as: get_reply_text(comment).appendTo( reply_comments.append($('') ...) Same comments below. |
|
|
Blank line between these. |
|
|
Alignment issue. |
|
|
Alignment problems. |
|
|
This looks wrong. |
|
|
Alignment issues. |
|
|
=== |
|
|
Not sure we want to remove this, since it's a core part of the data on the action. Why's it … |
|
|
What's this being used for? I'd prefer we call this "replied_to". This would require a serialize_replied_to function. |
|
|
I'm hesitant to say "comment" here. How about "The review that this is replying to." |
|