Comment serialization cleanup part 6: Fix terrible DiffFile names

Review Request #13660 — Created March 21, 2024 and submitted — Latest diff uploaded


Review Board


The DiffFile model (and the files context key when rendering
diffviewer templates) still used variable names from the very first days
of Review Board, when we used a fair bit of Perforce terminology.

This change fixes that to use orig_filename, orig_revision,
modified_filename, and modified_revision. This is a breaking change,
but I think that's okay for two reasons:

  1. The DiffFile model is pretty much an implementation detail of our
    diffviewer UI. It seems extremely unlikely that anybody would be
    digging into this.
  2. The documentation inside DiffFile was quite incorrect for many of
    the attributes. This was fixed in a prior change, but reinforces my
    belief that nobody was using it.

Ran python tests.
Ran js-tests.