Require GNU Diff for several SCMClients.

Review Request #12607 — Created Sept. 15, 2022 and submitted — Latest diff uploaded

chipx86
RBTools
release-4.x
rbtools

This updates Perforce, ClearCase, SOS, Subversion, and TFS to require
GNU Diff. These will be checked when a command starts up or when Python
code calls diff() on the client.

For now, we're explicitly requiring GNU Diff. Most of these will change
to allowing any tool, once everything has been updated appropriately.

This doesn't update the clients to use the new diff tool support yet. It
just sets the requirements.

check_gnu_diff() is now deprecated, and will be removed in RBTools 5.

Unit tests pass.

Tested a couple of these clients in test repositories, with and without
GNU Diff in the path. Verified that the commands failed if not found.

Commits

Files

Loading...