Rename Settings to ExtensionSettings and improve documentation.
Review Request #10641 — Created July 23, 2019 and submitted
The object that managed an extension's settings was called
which was a bit too generic and capable of conflicts. It also didn't
match the naming scheme of most other core Extension classes.
This change renames it to
ExtensionSettingsand improves its
documentation. It keeps an older
Settingsalias around for any legacy
purposes, which we'll remove in Djblets 3.0.
Unit tests pass.
Added missing files to the change.
Revision 2 (+89 -30)
Checks run (2 succeeded)