flake8
-
reviewboard/diffviewer/commit_utils.py (Diff revision 1) Show all issues -
-
-
reviewboard/diffviewer/diffutils.py (Diff revision 1) F841 local variable 'all_interfilediffs' is assigned to but never used
-
Review Request #10124 — Created Aug. 22, 2018 and submitted
Information | |
---|---|
brennie | |
Review Board | |
release-4.0.x | |
|
|
10130 | |
423f1c4... | |
Reviewers | |
reviewboard | |
When a review request is created with commit history, it is likely that
there will beFileDiff
s in multiple commits that modify the same file.
For anyFileDiff
in a commit, allFileDiff
s in previous commits are
known as "ancestor"FileDiff
s.These ancestor
FileDiff
s are now excluded from the diffviewer. This
removes the duplication of seeing the same file listed multiple times
with incremental changes. However, currently only the latest change for
that file is shown. True cumulative diffs are supported in /r/10130/.
Description | From | Last Updated |
---|---|---|
The first sentence of the description has some redundancy going on in the first sentence of the description. I'm also … |
|
|
E501 line too long (90 > 79 characters) |
![]() |
|
F821 undefined name 'diffset' |
![]() |
|
F821 undefined name 'f' |
![]() |
|
F841 local variable 'all_interfilediffs' is assigned to but never used |
![]() |
|
E501 line too long (82 > 79 characters) |
![]() |
|
E501 line too long (81 > 79 characters) |
![]() |
|
E501 line too long (96 > 79 characters) |
![]() |
|
Maybe this should be called get_leaf_filediffs? |
|
|
"FileDiffs" I feel like this could be worded better. Maybe: python """Return only the leafs in the list of FileDiffs.""" … |
|
|
This should be in the description. |
|
|
Can you move the list() to the next line, so it's more tightly coupled to the queryset? |
|
|
Alphabetical order. |
|
|
Missing docstring. |
|
reviewboard/diffviewer/commit_utils.py (Diff revision 1) |
---|
reviewboard/diffviewer/diffutils.py (Diff revision 1) |
---|
F841 local variable 'all_interfilediffs' is assigned to but never used
Summary: |
|
||||||||||||
---|---|---|---|---|---|---|---|---|---|---|---|---|---|
Testing Done: |
|
||||||||||||
Commit: |
|
||||||||||||
Diff: |
Revision 2 (+96 -21) |
reviewboard/diffviewer/tests/test_commit_utils.py (Diff revision 2) |
---|
E501 line too long (81 > 79 characters)
reviewboard/diffviewer/tests/test_commit_utils.py (Diff revision 2) |
---|
E501 line too long (96 > 79 characters)
flake8
Commit: |
|
||||
---|---|---|---|---|---|
Diff: |
Revision 3 (+99 -21) |
Fix unit test failures
Commit: |
|
||||
---|---|---|---|---|---|
Diff: |
Revision 4 (+106 -23) |
Fix unit test failures
Commit: |
|
||||
---|---|---|---|---|---|
Diff: |
Revision 5 (+115 -25) |
The first sentence of the description has some redundancy going on in the first sentence of the description.
I'm also just having a really hard time understanding this change from the description altogether.
reviewboard/diffviewer/commit_utils.py (Diff revision 5) |
---|
Maybe this should be called
get_leaf_filediffs
?
reviewboard/diffviewer/commit_utils.py (Diff revision 5) |
---|
"FileDiffs"
I feel like this could be worded better. Maybe:
python """Return only the leafs in the list of FileDiffs."""
With a description detailing what it means to be a leaf.
reviewboard/diffviewer/diffutils.py (Diff revision 5) |
---|
Can you move the
list()
to the next line, so it's more tightly coupled to the queryset?
Address feedback
Description: |
|
||||||||||||||||||||||||||||||||||||||||||
---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|
Commit: |
|
||||||||||||||||||||||||||||||||||||||||||
Diff: |
Revision 6 (+132 -25) |