-
-
Blank line between these. (Before/after if statements or other blocks when bunched up against code on the same indent level.)
-
-
-
We probably will want to change things such that stdout and stderr are not captured in this case, and instead are fed directly to the main stdout/stderr. Possibly need to support stdin too.
-
Wondering if we should put "The Review Board Project" as the author for all first-party commands, to better distinguish from third-party commands.
-
-
-
-
-
-
-
-
-
Base command class and 'rb post' command.
Review Request #3449 — Created Oct. 24, 2012 and submitted
This includes the beginnings of the new base class for rb commands, and the rb post command. 'rb post' is meant to eventually replace post-review for the common task of generating a diff and creating/updating a review request. It has many of the extra options of post-review stripped out, to make it more focused. "rb <command>" now uses the new entry points, expecting subclasses of ``Command``. If the command isn't found it will attempt to execute "rb-<command>" on the system.
Local testing with git repositories. This review request was posted using 'rb post'
Description | From | Last Updated |
---|---|---|
Blank line between these. (Before/after if statements or other blocks when bunched up against code on the same indent level.) |
chipx86 | |
Blank line between these. |
chipx86 | |
Blank line between these. |
chipx86 | |
Is that 'break' on the right indentation level? |
chipx86 | |
Indentation looks off on the 2nd and 3rd line. |
chipx86 | |
In this case, just use \ instead of parens. |
chipx86 | |
Blank line. |
chipx86 | |
Blank line. |
chipx86 | |
Can just use \ in this case. |
chipx86 | |
Probably should just do 'r/%s/' % .... That saves you the str() and is more readable. |
chipx86 | |
Can you build the filename first? It'll make this less awkward. |
chipx86 | |
Blank line should remain. |
chipx86 |
- Change Summary:
-
Fixes issues from Christian's review and update based on changes to the api.
- Summary:
-
Draft base command class and 'rb post' command.Base command class and 'rb post' command.
- Description:
-
~ This includes a draft of the new base class for rb commands, and the
~ rb post command. ~ This includes the beginnings of the new base class for rb commands,
~ and the rb post command. 'rb post' is meant to eventually replace post-review for the common
task of generating a diff and creating/updating a review request. It has many of the extra options of post-review stripped out, to make it more focused. "rb <command>" now uses the new entry points, expecting subclasses
of Command
. If the command isn't found it will attempt toexecute "rb-<command>" on the system.