Add new resources, part 4/7.
Review Request #14377 — Created March 20, 2025 and updated
This change adds the following new resource implementations:
- DiffCommentItemResource
- DiffCommentListResource
- GeneralCommentItemResource
- GeneralCommentListResource
- ReviewItemResource
- ReviewListResource
- ReviewReplyItemResource
- ReviewReplyListResource
- ScreenshotCommentItemResource
- ScreenshotCommentListResource
- Ran unit tests.
- Used the new resources from a test script and saw that everything
worked as expected.
Summary | ID |
---|---|
6fba8adcbfcb7cd6a29fdda4d9e3f36e9cee76bd |
Description | From | Last Updated | ||
---|---|---|---|---|
too many blank lines (2) Column: 5 Error code: E303 |
![]() |
|||
blank line at end of file Column: 1 Error code: W391 |
![]() |
|||
This needs to be removed. |
![]() |
|||
This needs to be removed. |
![]() |
|||
This needs to be removed. |
![]() |
|||
This needs to be removed. |
![]() |
|||
This needs to be removed. |
![]() |
|||
This should be "GeneralCommentListResource" |
![]() |
|||
Should say "list resource" |
![]() |
|||
Just a suggestion, but might be nice to format this like: issue_status: Optional[Literal[ 'dropped', 'open', 'resolved', ... ]] Keeps it … |
|
|||
Typo: contont -> content |
|
|||
Feel this reads better as "... only to the owner ..." |
|
|||
We should be explicit about what the line number refers to (the line of the generated diff, not of a … |
|
|||
These should be swapped. |
|
|||
Typo: "when" -> "that". |
|
|||
Can we list the version range? Same below. |
|
|||
"file attachment"? Same below. |
|
|||
This probably applies broadly, but given the "if present," I feel like I as the reader need to know what … |
|
|||
"file attachment" |
|
|||
There are no open issues |
- Commits:
-
Summary ID 6a041c1f0a2bc870ac34a3f681abd66d66502d89 94851572f3f4d2c91b7a638332db91d467f5cd81 - Diff:
-
Revision 2 (+4174 -16)
Checks run (2 succeeded)
- Commits:
-
Summary ID 94851572f3f4d2c91b7a638332db91d467f5cd81 2ed3c0a7cc644a6610a15aa3a4548faaa9f14270 - Diff:
-
Revision 3 (+4144 -16)
Checks run (2 succeeded)
-
-
Just a suggestion, but might be nice to format this like:
issue_status: Optional[Literal[ 'dropped', 'open', 'resolved', ... ]]
Keeps it a bit more readable, and easier to keep in a nice alphabetical order.
-
-
-
We should be explicit about what the line number refers to (the line of the generated diff, not of a file).
Same below.
-
-
-
-
-
This probably applies broadly, but given the "if present," I feel like I as the reader need to know what I should expect if it's not present. The exceptions look like actual errors, and this doesn't return
None
. -
- Commits:
-
Summary ID 2ed3c0a7cc644a6610a15aa3a4548faaa9f14270 6fba8adcbfcb7cd6a29fdda4d9e3f36e9cee76bd - Diff:
-
Revision 4 (+4236 -68)